r2213: *** empty log message ***
[ctsim.git] / debian / rules
index 3b1475b04fc62b8b625b5443870d05f4a5419a37..d81103bc73f10751b3fd99e64d02317ebf444181 100755 (executable)
@@ -3,24 +3,29 @@
 # GNU copyright 1997 to 1999 by Joey Hess.
 
 # Uncomment this to turn on verbose mode.
-export DH_VERBOSE=1
+export DH_VERBOSE=1
 
 # This is the debhelper compatibility version to use.
-export DH_COMPAT=3
+export DH_COMPAT=4
 
-pkg    := ctsim
-prefix := debian/$(pkg)
-DESTDIR := `pwd`/$(prefix)
+pkg            := ctsim
+pkg-help       := ctsim-help
+pkg-doc                := ctsim-doc
 
-INSTALL        := install
-INSTALLFLAGS   := -g root -o root -m 0644
-INSTALLDIRFLAGS        := -d -g root -o root -m 0755
+prefix         := debian/$(pkg)
+prefix-help    := debian/$(pkg-help)
+prefix-doc     := debian/$(pkg-doc)
+
+DESTDIR                := `pwd`/$(prefix)
+HELPDIR                := `pwd`/$(prefix-help)/usr/share/ctsim
+doc-dir                := usr/share/doc/$(pkg-doc)
+pixmap-dir     := usr/X11R6/include/X11/pixmaps
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
        touch configure-stamp
 
 
@@ -29,7 +34,7 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
        # Add here commands to compile the package.
-       $(MAKE) 
+       $(MAKE) all
        touch build-stamp
 
 clean:
@@ -47,24 +52,28 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
-
-       # Add here commands to install the package into debian/ctsim.
-       # install ${INSTALLDIRFLAGS} 
+       # Below command also installs helpfile, man pages
        ${MAKE} install
+       dh_installdirs -p $(pkg) $(pixmap-dir)
+       dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
+
+       dh_install -p $(pkg-doc) docs/html $(doc-dir)
+       dh_link -p $(pkg-doc) $(doc-dir)/html/$(pkg)_contents.html $(doc-dir)/html/index.html
+       gzip -9 docs/ctsim.pdf
+       dh_install -p $(pkg-doc) docs/ctsim.pdf.gz $(doc-dir)
 
 # Build architecture-independent files here.
 binary-indep: build install
 
 
-
 # Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
-       dh_installdocs doc/html
+       dh_installdebconf       
+       dh_installdocs -A 
        dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
-#      dh_installmenu
+       dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen
 #      dh_installpam
@@ -82,7 +91,7 @@ binary-arch: build install
 #      dh_makeshlibs
        dh_installdeb
 #      dh_perl
-#      dh_shlibdeps
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb