r2213: *** empty log message ***
[ctsim.git] / debian / rules
index ad695b924edff933d3ca49200a449634c9967919..d81103bc73f10751b3fd99e64d02317ebf444181 100755 (executable)
@@ -3,10 +3,10 @@
 # GNU copyright 1997 to 1999 by Joey Hess.
 
 # Uncomment this to turn on verbose mode.
-export DH_VERBOSE=0
+# export DH_VERBOSE=1
 
 # This is the debhelper compatibility version to use.
-export DH_COMPAT=3
+export DH_COMPAT=4
 
 pkg            := ctsim
 pkg-help       := ctsim-help
@@ -18,11 +18,8 @@ prefix-doc   := debian/$(pkg-doc)
 
 DESTDIR                := `pwd`/$(prefix)
 HELPDIR                := `pwd`/$(prefix-help)/usr/share/ctsim
-DOCDIR         := $(prefix-doc)/usr/share/doc/ctsim-doc
-
-INSTALL                := install
-INSTALLFLAGS   := -g root -o root -m 0644
-INSTALLDIRFLAGS        := -d -g root -o root -m 0755
+doc-dir                := usr/share/doc/$(pkg-doc)
+pixmap-dir     := usr/X11R6/include/X11/pixmaps
 
 configure: configure-stamp
 configure-stamp:
@@ -55,15 +52,15 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
-       # Below command also installs helpfile
+       # Below command also installs helpfile, man pages
        ${MAKE} install
-       $(INSTALL) $(INSTALLFLAGS) debian/ctsim.xpm $(prefix)/usr/X11R6/include/X11/pixmaps
-
-       $(INSTALL) $(INSTALLFLAGS) $(shell echo docs/html/*) $(DOCDIR)/html
-       ln -sf $(pkg)_contents.html $(DOCDIR)/html/index.html
+       dh_installdirs -p $(pkg) $(pixmap-dir)
+       dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
 
-       $(INSTALL) $(INSTALLFLAGS) docs/ctsim.pdf $(DOCDIR)
-       gzip -9 $(DOCDIR)/ctsim.pdf
+       dh_install -p $(pkg-doc) docs/html $(doc-dir)
+       dh_link -p $(pkg-doc) $(doc-dir)/html/$(pkg)_contents.html $(doc-dir)/html/index.html
+       gzip -9 docs/ctsim.pdf
+       dh_install -p $(pkg-doc) docs/ctsim.pdf.gz $(doc-dir)
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -73,7 +70,7 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
+       dh_installdebconf       
        dh_installdocs -A 
        dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
        dh_installmenu
@@ -94,7 +91,7 @@ binary-arch: build install
 #      dh_makeshlibs
        dh_installdeb
 #      dh_perl
-#      dh_shlibdeps
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb