r3908: Automatic commit for debian_version_4_1_0-1
[ctsim.git] / debian / rules
index 1a14078037ea151238ed8fd506800cb35ca81111..e02ab07707091db41f92ae975450c0907b8f37d7 100755 (executable)
@@ -15,7 +15,6 @@ pkg           := ctsim
 pkg-p4         := ctsim-pentium4
 pkg-p3         := ctsim-pentium3
 pkg-athlon     := ctsim-athlon
-pkg-athlon-mp  := ctsim-athlon-mp
 pkg-help       := ctsim-help
 pkg-doc                := ctsim-doc
 
@@ -25,7 +24,6 @@ prefix                := debian/$(pkg)
 prefix-p4      := debian/$(pkg-p4)
 prefix-p3      := debian/$(pkg-p3)
 prefix-athlon  := debian/$(pkg-athlon)
-prefix-athlon-mp:= debian/$(pkg-athlon-mp)
 prefix-help    := debian/$(pkg-help)
 prefix-doc     := debian/$(pkg-doc)
 
@@ -33,7 +31,6 @@ DESTDIR               := `pwd`/$(prefix)
 DESTDIR-P4     := `pwd`/$(prefix-p4)
 DESTDIR-P3     := `pwd`/$(prefix-p3)
 DESTDIR-ATHLON := `pwd`/$(prefix-athlon)
-DESTDIR-ATHLON-MP      := `pwd`/$(prefix-athlon-mp)
 HELPDIR                := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
 pixmap-dir     := usr/X11R6/include/X11/pixmaps
@@ -104,19 +101,12 @@ ifneq (,$(findstring i386,$(host_arch)))
        ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
        $(MAKE) all
        ${MAKE} install
-       # Athlon MP
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-ATHLON-MP)/usr --mandir=$(DESTDIR-ATHLON-MP)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon-mp
-       $(MAKE) all
-       ${MAKE} install
-       dh_installdirs -p $(pkg-p) $(pixmap-dir)
+       dh_installdirs -p $(pkg-p3) $(pixmap-dir)
        dh_installdirs -p $(pkg-p4) $(pixmap-dir)
        dh_installdirs -p $(pkg-athlon) $(pixmap-dir)
-       dh_installdirs -p $(pkg-athlon-mp) $(pixmap-dir)
-       dh_install -p $(pkg-p) debian/ctsim.xpm $(pixmap-dir)
+       dh_install -p $(pkg-p3) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-athlon) debian/ctsim.xpm $(pixmap-dir)
-       dh_install -p $(pkg-athlon-mp) debian/ctsim.xpm $(pixmap-dir)
 endif
        # Add here commands to install the package into debian/ctsim.
        dh_installdirs -p $(pkg) $(pixmap-dir)
@@ -163,7 +153,12 @@ binary-arch: build install
        dh_testroot -a
 #      dh_installdebconf -a
        dh_installdocs -a
-       dh_installexamples -a tools/sample-ctsim.sh helical/sample-helical.sh
+       dh_installexamples - $(pkg) tools/sample-ctsim.sh helical/sample-helical.sh
+ifneq (,$(findstring i386,$(host_arch)))
+       dh_installexamples - $(pkg-p3) tools/sample-ctsim.sh helical/sample-helical.sh
+       dh_installexamples - $(pkg-p4) tools/sample-ctsim.sh helical/sample-helical.sh
+       dh_installexamples - $(pkg-athlon) tools/sample-ctsim.sh helical/sample-helical.sh
+endif
        dh_installmenu -a
 #      dh_installlogrotate -a
 #      dh_installemacsen -a
@@ -187,10 +182,9 @@ binary-arch: build install
        dh_md5sums -a
        dh_builddeb -p $(pkg)
 ifneq (,$(findstring i386,$(host_arch)))
-       dh_builddeb -p $(pkg-p)
+       dh_builddeb -p $(pkg-p3)
        dh_builddeb -p $(pkg-p4)
        dh_builddeb -p $(pkg-athlon)
-       dh_builddeb -p $(pkg-athlon-mp)
 endif
 
 binary: binary-indep binary-arch