r1865: *** empty log message ***
[ctsim.git] / debian / rules
index 432e18a03ea4b1bcb3b688f92cee87127cac1da9..e076c2a37eb46392b2e8c4fa8e89c6b92d2e482d 100755 (executable)
@@ -11,6 +11,7 @@ export DH_COMPAT=3
 pkg    := ctsim
 prefix := debian/$(pkg)
 DESTDIR := `pwd`/$(prefix)
+SHAREDOCDIR := $(DESTDIR)/usr/share/$(pkg)
 
 INSTALL        := install
 INSTALLFLAGS   := -g root -o root -m 0644
@@ -28,23 +29,19 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-
        # Add here commands to compile the package.
        $(MAKE) 
-       #/usr/bin/docbook-to-man debian/uffi.sgml > uffi.1
-
+       (cd doc; $(MAKE) htmlhelp)
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-
        # Add here commands to clean up after the build process.
        -$(MAKE) distclean
-       find . -type f -and -name *~ -or -name .*~ -exec rm -f {} \;
+       find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
-
        dh_clean
 
 install: build
@@ -56,6 +53,7 @@ install: build
        # Add here commands to install the package into debian/ctsim.
        # install ${INSTALLDIRFLAGS} 
        ${MAKE} install
+       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/*.htb) $(SHAREDOCDIR)
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -67,7 +65,7 @@ binary-arch: build install
        dh_testdir
        dh_testroot
 #      dh_installdebconf       
-#      dh_installdocs
+       dh_installdocs doc/html
        dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
 #      dh_installmenu
 #      dh_installlogrotate