r1883: *** empty log message ***
[ctsim.git] / debian / rules
index 3b1475b04fc62b8b625b5443870d05f4a5419a37..e6f5956fed2e08832a3d3c6a45e7b14737d3cd7a 100755 (executable)
@@ -11,6 +11,8 @@ export DH_COMPAT=3
 pkg    := ctsim
 prefix := debian/$(pkg)
 DESTDIR := `pwd`/$(prefix)
+SHAREDOCDIR := $(DESTDIR)/usr/share/doc/$(pkg)
+SHAREDATADIR := $(DESTDIR)/usr/share/$(pkg)/.
 
 INSTALL        := install
 INSTALLFLAGS   := -g root -o root -m 0644
@@ -20,7 +22,7 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(SHAREDATADIR)
        touch configure-stamp
 
 
@@ -29,7 +31,7 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
        # Add here commands to compile the package.
-       $(MAKE) 
+       $(MAKE) all
        touch build-stamp
 
 clean:
@@ -47,16 +49,15 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
-
        # Add here commands to install the package into debian/ctsim.
-       # install ${INSTALLDIRFLAGS} 
        ${MAKE} install
+       $(INSTALL) $(INSTALLFLAGS) $(shell echo doc/html/*) $(SHAREDOCDIR)/html
+       ln -sf $(pkg)_contents.html $(SHAREDOCDIR)/html/index.html
 
 # Build architecture-independent files here.
 binary-indep: build install
 
 
-
 # Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir