r1883: *** empty log message ***
[ctsim.git] / debian / rules
index 432e18a03ea4b1bcb3b688f92cee87127cac1da9..e6f5956fed2e08832a3d3c6a45e7b14737d3cd7a 100755 (executable)
@@ -11,6 +11,8 @@ export DH_COMPAT=3
 pkg    := ctsim
 prefix := debian/$(pkg)
 DESTDIR := `pwd`/$(prefix)
+SHAREDOCDIR := $(DESTDIR)/usr/share/doc/$(pkg)
+SHAREDATADIR := $(DESTDIR)/usr/share/$(pkg)/.
 
 INSTALL        := install
 INSTALLFLAGS   := -g root -o root -m 0644
@@ -20,7 +22,7 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(SHAREDATADIR)
        touch configure-stamp
 
 
@@ -28,23 +30,18 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-
        # Add here commands to compile the package.
-       $(MAKE) 
-       #/usr/bin/docbook-to-man debian/uffi.sgml > uffi.1
-
+       $(MAKE) all
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-
        # Add here commands to clean up after the build process.
        -$(MAKE) distclean
-       find . -type f -and -name *~ -or -name .*~ -exec rm -f {} \;
+       find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
-
        dh_clean
 
 install: build
@@ -52,22 +49,21 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
-
        # Add here commands to install the package into debian/ctsim.
-       # install ${INSTALLDIRFLAGS} 
        ${MAKE} install
+       $(INSTALL) $(INSTALLFLAGS) $(shell echo doc/html/*) $(SHAREDOCDIR)/html
+       ln -sf $(pkg)_contents.html $(SHAREDOCDIR)/html/index.html
 
 # Build architecture-independent files here.
 binary-indep: build install
 
 
-
 # Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir
        dh_testroot
 #      dh_installdebconf       
-#      dh_installdocs
+       dh_installdocs doc/html
        dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
 #      dh_installmenu
 #      dh_installlogrotate