r1883: *** empty log message ***
[ctsim.git] / debian / rules
index 79fd21213eebdf823fc775b0581c8d152b54ecbb..e6f5956fed2e08832a3d3c6a45e7b14737d3cd7a 100755 (executable)
@@ -10,22 +10,19 @@ export DH_COMPAT=3
 
 pkg    := ctsim
 prefix := debian/$(pkg)
+DESTDIR := `pwd`/$(prefix)
+SHAREDOCDIR := $(DESTDIR)/usr/share/doc/$(pkg)
+SHAREDATADIR := $(DESTDIR)/usr/share/$(pkg)/.
 
 INSTALL        := install
 INSTALLFLAGS   := -g root -o root -m 0644
 INSTALLDIRFLAGS        := -d -g root -o root -m 0755
 
-SOURCEDIR      := $(prefix)/usr/share/common-lisp/source
-REPOSITORYDIR  := $(prefix)/usr/share/common-lisp/repositories/uffi
-SYSDIR         := $(prefix)/usr/share/common-lisp/systems
-DOCDIR         := $(prefix)/usr/share/doc/cl-uffi
-
-
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(SHAREDATADIR)
        touch configure-stamp
 
 
@@ -33,22 +30,18 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-
        # Add here commands to compile the package.
-       $(MAKE) doc
-       #/usr/bin/docbook-to-man debian/uffi.sgml > uffi.1
-
+       $(MAKE) all
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-       rm -f debian/cl-uffi.postinst.* debian/cl-uffi.prerm.*
-
+       -$(MAKE) distclean
+       find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
+       rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
        dh_clean
 
 install: build
@@ -56,21 +49,22 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
-
        # Add here commands to install the package into debian/ctsim.
+       ${MAKE} install
+       $(INSTALL) $(INSTALLFLAGS) $(shell echo doc/html/*) $(SHAREDOCDIR)/html
+       ln -sf $(pkg)_contents.html $(SHAREDOCDIR)/html/index.html
 
 # Build architecture-independent files here.
 binary-indep: build install
 
 
-
 # Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir
        dh_testroot
 #      dh_installdebconf       
-       dh_installdocs
-       dh_installexamples examples/*.cl
+       dh_installdocs doc/html
+       dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
 #      dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen
@@ -82,7 +76,7 @@ binary-arch: build install
 #      dh_installinfo
 #      dh_undocumented
        dh_installchangelogs ChangeLog
-       dh_link
+#      dh_link
        dh_strip
        dh_compress
        dh_fixperms