r3893: Automatic commit for debian_version_4_1_0-1
[ctsim.git] / debian / rules
index 17539538886538213055fc232233ecd595820a15..ff7c2d94f6c88158ccd0a8fc4d17349722b8fc6d 100755 (executable)
@@ -2,6 +2,15 @@
 
 export DH_COMPAT=4
 
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -g
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+       INSTALL_PROGRAM += -s
+endif
+
+host_arch      := $(dpkg-architecture -qDEB_HOST_ARCH)
+
 pkg            := ctsim
 pkg-p4         := ctsim-pentium4
 pkg-athlon     := ctsim-athlon
@@ -23,6 +32,7 @@ HELPDIR               := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
 pixmap-dir     := usr/X11R6/include/X11/pixmaps
 
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
@@ -38,14 +48,18 @@ build-arch-stamp:
        ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
        $(MAKE) all
        ${MAKE} install
+ifeq ($(host_arch),i386)
+       # Pentium 4
        ${MAKE} clean
        ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
        $(MAKE) all
        ${MAKE} install
+       # Athlon
        ${MAKE} clean
        ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
        $(MAKE) all
        ${MAKE} install
+endif
        touch build-arch-stamp
 
 build-indep: configure-stamp  build-indep-stamp