r1850: *** empty log message ***
[ctsim.git] / doc / Makefile.am
index 558768be7926cfca986dd417f4becd1b62fc6cbb..684a3338b05ded3159294d350f093a46c3773f0a 100644 (file)
@@ -9,7 +9,12 @@ mysober.sty fancyhea.sty ctsim.bib ctsim-latex.bib ctsim-tex2rtf.bib
 
 EXTRA_DIST = ${docs} ctsim.htb 
 
-dvi: ctsim.tex
+ps: ctsim.ps
+ctsim.ps: ctsim.dvi
+       dvips ctsim
+
+dvi: ctsim.dvi
+ctsim.dvi: $(docs)
        cp ctsim-latex.bib ctsim.bib
        latex ctsim
        bibtex ctsim
@@ -17,7 +22,7 @@ dvi: ctsim.tex
        makeindex ctsim
        latex ctsim
 
-winhelp: ctsim.tex
+winhelp: $(docs)
        rm -f ctsim.rtf ctsim.cnt
        cp ctsim-tex2rtf.bib ctsim.bib
        tex2rtf ctsim.tex ctsim.rtf -winhelp
@@ -33,4 +38,12 @@ htmlhelp: ctsim.tex
        mv ctsim.zip ctsim.htb
        cp ctsim.htb ../msvc/ctsim/.
        cp ctsim.htb ../src/.
+
+html: $(docs)
+       rm -f ctsim*.html ctsim.hhp ctsim.hhc ctsim.hhk ctsim.zip
+       cp ctsim-tex2rtf.bib ctsim.bib
+       tex2rtf ctsim.tex ctsim.html -html
+       rm -rf html
+       mkdir html
+       ln -s ctsim_contents.html html/index.html
+       mv *.html *.gif html