r1881: *** empty log message ***
[ctsim.git] / doc / Makefile.am
index 91716e0547f96dec6029e48ecd36f5bc68851596..80fcbfac849a180f4e8b1ea8551ddb9474f1593e 100644 (file)
@@ -1,4 +1,4 @@
-docs = ctsim.tex texhelp.sty psbox.tex logo.eps logo.gif ctsim-sgp.tex ctsim-concepts.tex ctsim-gui.tex ctsim-install.tex ctsim-textui.tex ctsim-web.tex alphacalc.eps alphacalc.gif divergent.eps divergent.gif equiangular.eps equiangular.gif equilinear.eps equilinear.gif scangeometry.eps scangeometry.gif tex2rtf.ini ctsim.hpj bullet.bmp verbatim.sty mytitle.sty makeidx.sty mysober.sty fancyhea.sty ctsim-latex.bib ctsim-tex2rtf.bib
+docs := ctsim.tex texhelp.sty psbox.tex logo.eps logo.gif ctsim-sgp.tex ctsim-concepts.tex ctsim-gui.tex ctsim-install.tex ctsim-textui.tex ctsim-web.tex alphacalc.eps alphacalc.gif divergent.eps divergent.gif equiangular.eps equiangular.gif equilinear.eps equilinear.gif scangeometry.eps scangeometry.gif tex2rtf.ini ctsim.hpj bullet.bmp verbatim.sty mytitle.sty makeidx.sty mysober.sty fancyhea.sty ctsim-latex.bib ctsim-tex2rtf.bib
 
 pkg=ctsim
 
@@ -11,7 +11,7 @@ CLEANFILES=$(pkg).ps $(pkg)*.html $(pkg).hhc $(pkg).hhp $(pkg).hhk \
 all-local: htmlhelp html dvi 
 
 install-data-hook: $(pkg).htb
-       cp $(pkg).htb $(datadir)
+       install -g root -o root -m 0644 $(pkg).htb $(datadir)
 
 .PHONY: ps
 ps: ctsim.ps
@@ -42,7 +42,7 @@ htmlhelp: $(docs)
        rm -f $(pkg)*.html $(pkg).hhp $(pkg).hhc $(pkg).hhk $(pkg).zip
        cp $(pkg)-tex2rtf.bib $(pkg).bib
        tex2rtf $(pkg).tex $(pkg).html -html  > /dev/null
-       zip $(pkg).zip *.html *.gif $(pkg).hh[pck]
+       zip -q $(pkg).zip *.html *.gif $(pkg).hh[pck]
        mv $(pkg).zip $(pkg).htb
 
 html: $(docs)
@@ -51,6 +51,7 @@ html: $(docs)
        tex2rtf $(pkg).tex $(pkg).html -html  > /dev/null
        rm -rf html
        mkdir html
-       ln -s $(pkg)_contents.html html/index.html
+       cp *.gif html
+       mv *.html html