r553: *** empty log message ***
[ctsim.git] / doc / Makefile.am
index fa0c8f680622026baf33e58010167773e8f4b051..d6bdca3955184dfba05ec65fe8da773b1e705425 100644 (file)
@@ -1,6 +1,27 @@
-docs=sgp.doc tex2rtf/ctsim.tex tex2rtf/ctsim.bib tex2rtf/texhelp.sty tex2rtf/psbox.tex tex2rtf/logo-huge.bmp tex2rtf/tex2rtf.ini tex2rtf/ctsim.hpj tex2rtf/ctsim.cnt tex2rtf/bullet.bmp 
-info_INFO=ctsim.texi
-EXTRA_DIST = ${docs} $(info_INFO) 
+docs=ctsim.tex ctsim.bib texhelp.sty psbox.tex logo-huge.gif alphacalc.gif divergent.gif equiangular.gif equilinear.gif scangeometry.gif tex2rtf.ini ctsim.hpj bullet.bmp verbatim.sty mytitle.sty makeidx.sty mysober.sty fancyhea.sty ctsim.bib 
+EXTRA_DIST = ${docs} ctsim.htb 
 
 dvi: ctsim.tex
-       latex ctsim.tex
+       bibtex ctsim
+       cp ctsim-latex.bib ctsim.bib
+       latex ctsim
+       makeindex ctsim
+       latex ctsim
+
+winhelp: ctsim.tex
+       rm -f ctsim.rtf ctsim.cnt
+       cp ctsim-tex2rtf.bib ctsim.bib
+       tex2rtf ctsim.tex ctsim.rtf -winhelp
+       hcw /c /m /e ctsim.hpj
+       mv CTSIM.HLP ctsim.hlp
+       cp ctsim.hlp ctsim.cnt ../msvc/ctsim/
+
+htmlhelp: ctsim.tex
+       rm -f ctsim*.html ctsim.hhp ctsim.hhc ctsim.hhk ctsim.zip
+       cp ctsim-tex2rtf.bib ctsim.bib
+       tex2rtf ctsim.tex ctsim.html -html
+       zip ctsim.zip *.html *.gif ctsim.hhp ctsim.hhc ctsim.hhk
+       mv ctsim.zip ctsim.htb
+       cp ctsim.htb ../msvc/ctsim/.
+       cp ctsim.htb ../src/.