r1883: *** empty log message ***
[ctsim.git] / doc / Makefile.am
index 528ae6031e6e86053e2dc01a0f9a0d82f6ea61b5..dfa0d19ca9543dfc8ed959fe006e953a47273961 100644 (file)
@@ -1,27 +1,54 @@
-docs=ctsim.tex ctsim.bib texhelp.sty psbox.tex logo-huge.bmp tex2rtf.ini ctsim.hpj bullet.bmp verbatim.sty mytitle.sty makeidx.sty mysober.sty fancyhea.sty ctsim.bib 
-EXTRA_DIST = ${docs} ctsim.htb 
-
-dvi: ctsim.tex
-       bibtex ctsim
-       cp ctsim-latex.bib ctsim.bib
-       latex ctsim
-       makeindex ctsim
-       latex ctsim
-
-winhelp: ctsim.tex
-       rm -f ctsim.rtf ctsim.cnt
-       cp ctsim-tex2rtf.bib ctsim.bib
-       tex2rtf ctsim.tex ctsim.rtf -winhelp
-       hcw /c /m /e ctsim.hpj
-       mv CTSIM.HLP ctsim.hlp
-       cp ctsim.hlp ctsim.cnt ../msvc/ctsim/
-
-htmlhelp: ctsim.tex
-       rm -f ctsim*.html ctsim.hhp ctsim.hhc ctsim.hhk ctsim.zip
-       cp ctsim-tex2rtf.bib ctsim.bib
-       tex2rtf ctsim.tex ctsim.html -html
-       zip ctsim.zip *.html *.gif ctsim.hhp ctsim.hhc ctsim.hhk
-       mv ctsim.zip ctsim.htb
-       cp ctsim.htb ../msvc/ctsim/.
-       cp ctsim.htb ../src/.
+docs := ctsim.tex texhelp.sty psbox.tex logo.eps logo.gif ctsim-sgp.tex ctsim-concepts.tex ctsim-gui.tex ctsim-install.tex ctsim-textui.tex ctsim-web.tex alphacalc.eps alphacalc.gif divergent.eps divergent.gif equiangular.eps equiangular.gif equilinear.eps equilinear.gif scangeometry.eps scangeometry.gif tex2rtf.ini ctsim.hpj bullet.bmp verbatim.sty mytitle.sty makeidx.sty mysober.sty fancyhea.sty ctsim-latex.bib ctsim-tex2rtf.bib
+
+pkg=ctsim
+
+EXTRA_DIST = $(docs) html
+
+CLEANFILES=$(pkg).ps $(pkg)*.html $(pkg).hhc $(pkg).hhp $(pkg).hhk \
+       $(pkg).bib $(pkg).zip *.aux *.log *~ \#*~ \#*\# \.*~ \
+       $(pkg).ilg $(pkg).ind
+
+all-local: htmlhelp html pdf
+
+install-data-hook: $(pkg).htb
+       install -g root -o root -m 0644 $(pkg).htb $(datadir)
+
+.PHONY: pdf
+pdf: ctsim.pdf
+$(pkg).pdf: $(pkg).dvi
+       dvipdfm $(pkg)
+
+.PHONY: dvi
+dvi: $(pkg).dvi
+$(pkg).dvi: $(docs)
+       cp $(pkg)-latex.bib $(pkg).bib
+       latex $(pkg) > /dev/null
+       bibtex $(pkg) > /dev/null
+       latex $(pkg) > /dev/null
+       makeindex $(pkg) > /dev/null
+       latex $(pkg) > /dev/null
+
+.PHONY: winhelp
+winhelp: $(docs)
+       rm -f $(pkg).rtf $(pkg).cnt
+       cp $(pkg)-tex2rtf.bib $(pkg).bib
+       tex2rtf $(pkg).tex $(pkg).rtf -winhelp
+       hcw /c /m /e $(pkg).hpj
+       mv $(PKG).HLP $(pkg).hlp
+       cp $(pkg).hlp $(pkg).cnt ../msvc/$(pkg)/
+
+.PHONY: htmlhelp
+htmlhelp: $(docs)
+       rm -f $(pkg)*.html $(pkg).hhp $(pkg).hhc $(pkg).hhk $(pkg).zip
+       cp $(pkg)-tex2rtf.bib $(pkg).bib
+       tex2rtf $(pkg).tex $(pkg).html -html  > /dev/null
+       zip -q $(pkg).zip *.html *.gif $(pkg).hh[pck]
+       mv $(pkg).zip $(pkg).htb
+
+html: htmlhelp
+       rm -rf html
+       mkdir html
+       cp *.gif html
+       mv *.html html
+
+