r1883: *** empty log message ***
[ctsim.git] / doc / Makefile.am
index 91716e0547f96dec6029e48ecd36f5bc68851596..dfa0d19ca9543dfc8ed959fe006e953a47273961 100644 (file)
@@ -1,4 +1,4 @@
-docs = ctsim.tex texhelp.sty psbox.tex logo.eps logo.gif ctsim-sgp.tex ctsim-concepts.tex ctsim-gui.tex ctsim-install.tex ctsim-textui.tex ctsim-web.tex alphacalc.eps alphacalc.gif divergent.eps divergent.gif equiangular.eps equiangular.gif equilinear.eps equilinear.gif scangeometry.eps scangeometry.gif tex2rtf.ini ctsim.hpj bullet.bmp verbatim.sty mytitle.sty makeidx.sty mysober.sty fancyhea.sty ctsim-latex.bib ctsim-tex2rtf.bib
+docs := ctsim.tex texhelp.sty psbox.tex logo.eps logo.gif ctsim-sgp.tex ctsim-concepts.tex ctsim-gui.tex ctsim-install.tex ctsim-textui.tex ctsim-web.tex alphacalc.eps alphacalc.gif divergent.eps divergent.gif equiangular.eps equiangular.gif equilinear.eps equilinear.gif scangeometry.eps scangeometry.gif tex2rtf.ini ctsim.hpj bullet.bmp verbatim.sty mytitle.sty makeidx.sty mysober.sty fancyhea.sty ctsim-latex.bib ctsim-tex2rtf.bib
 
 pkg=ctsim
 
@@ -8,15 +8,15 @@ CLEANFILES=$(pkg).ps $(pkg)*.html $(pkg).hhc $(pkg).hhp $(pkg).hhk \
        $(pkg).bib $(pkg).zip *.aux *.log *~ \#*~ \#*\# \.*~ \
        $(pkg).ilg $(pkg).ind
 
-all-local: htmlhelp html dvi 
+all-local: htmlhelp html pdf
 
 install-data-hook: $(pkg).htb
-       cp $(pkg).htb $(datadir)
+       install -g root -o root -m 0644 $(pkg).htb $(datadir)
 
-.PHONY: ps
-ps: ctsim.ps
-$(pkg).ps: $(pkg).dvi
-       dvips $(pkg)
+.PHONY: pdf
+pdf: ctsim.pdf
+$(pkg).pdf: $(pkg).dvi
+       dvipdfm $(pkg)
 
 .PHONY: dvi
 dvi: $(pkg).dvi
@@ -42,15 +42,13 @@ htmlhelp: $(docs)
        rm -f $(pkg)*.html $(pkg).hhp $(pkg).hhc $(pkg).hhk $(pkg).zip
        cp $(pkg)-tex2rtf.bib $(pkg).bib
        tex2rtf $(pkg).tex $(pkg).html -html  > /dev/null
-       zip $(pkg).zip *.html *.gif $(pkg).hh[pck]
+       zip -q $(pkg).zip *.html *.gif $(pkg).hh[pck]
        mv $(pkg).zip $(pkg).htb
 
-html: $(docs)
-       rm -f $(pkg)*.html $(pkg).hh[cpk] $(pkg).zip
-       cp $(pkg)-tex2rtf.bib $(pkg).bib
-       tex2rtf $(pkg).tex $(pkg).html -html  > /dev/null
+html: htmlhelp
        rm -rf html
        mkdir html
-       ln -s $(pkg)_contents.html html/index.html
+       cp *.gif html
+       mv *.html html