Updates for new debian standards
[pipes.git] / debian / rules
index f359b70a14c92e8421f0ced216a0637359f7b20a..e7b6043a8e8a40c017066f223288bdabb33b4ab1 100755 (executable)
@@ -6,67 +6,44 @@ debpkg  := cl-pipes
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
 clc-pipes      := $(clc-source)/$(pkg)
-
 doc-dir                := usr/share/doc/$(debpkg)
 
-
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
-
        touch configure-stamp
 
-
 build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-       # Add here commands to compile the package.
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
        rm -f debian/cl-pipes.postinst.* debian/cl-pipes.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/pipes.
+       dh_prep
        dh_installdirs $(clc-systems) $(clc-pipes) $(doc-dir)
        dh_install pipes.asd $(shell echo *.lisp) $(clc-pipes)
        dh_link $(clc-pipes)/pipes.asd $(clc-systems)/pipes.asd
 
-# Build architecture-independent files here.
 binary-indep: build install
        dh_testdir -i 
        dh_testroot -i
-#      dh_installdebconf       
        dh_installdocs -i
        dh_installexamples -i pipes-example.lisp
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
        dh_installchangelogs -i
        dh_strip -i
        dh_compress -i
        dh_fixperms -i
-#      dh_makeshlibs
        dh_installdeb -i
-#      dh_perl
-       dh_shlibdeps -i
        dh_gencontrol -i
        dh_md5sums -i
        dh_builddeb -i
@@ -76,4 +53,3 @@ binary-arch: build install
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure
-