Updates for new debian standards
[umlisp.git] / debian / rules
index b6f1d5d286dce46159e5c2960b63d650b01d0c80..b7fc0f46dcc07a34cbf12336cbf2591f3601d425 100755 (executable)
@@ -3,19 +3,14 @@
 pkg    := umlisp
 debpkg  := cl-umlisp
 
-
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
 clc-umlisp     := $(clc-source)/$(pkg)
-
 doc-dir                := usr/share/doc/$(debpkg)
 
-
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
-
        touch configure-stamp
 
 
@@ -23,46 +18,37 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-       # Add here commands to compile the package.
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
        rm -f debian/cl-umlisp.postinst.* debian/cl-umlisp.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/umlisp.
+       dh_prep
        dh_installdirs $(clc-systems) $(clc-umlisp) $(doc-dir)
        dh_install umlisp.asd $(shell echo *.lisp) $(clc-umlisp)
-       #dh_install $(shell echo *.html) $(doc-dir)
        dh_link $(clc-umlisp)/umlisp.asd $(clc-systems)/umlisp.asd
 
-# Build architecture-independent files here.
 binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
+       dh_testdir -i
+       dh_testroot -i
+       dh_installdocs -i
+       dh_installchangelogs -i
+       dh_strip -i
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
 
-
-# Build architecture-dependent files here.
 binary-arch: build install
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure
-