fix for mysql 5
[umlisp.git] / -orf / debian / rules
1 #!/usr/bin/make -f
2
3 pkg     := umlisp-orf
4 debpkg  := cl-umlisp-orf
5
6
7 clc-source      := usr/share/common-lisp/source
8 clc-systems     := usr/share/common-lisp/systems
9 clc-umlisp-orf  := $(clc-source)/$(pkg)
10
11 doc-dir         := usr/share/doc/$(debpkg)
12
13
14 configure: configure-stamp
15 configure-stamp:
16         dh_testdir
17         # Add here commands to configure the package.
18
19         touch configure-stamp
20
21
22 build: build-stamp
23
24 build-stamp: configure-stamp 
25         dh_testdir
26         # Add here commands to compile the package.
27         touch build-stamp
28
29 clean:
30         dh_testdir
31         dh_testroot
32         rm -f build-stamp configure-stamp
33         # Add here commands to clean up after the build process.
34         rm -f debian/cl-umlisp-orf.postinst.* debian/cl-umlisp-orf.prerm.*
35         dh_clean
36
37 install: build
38         dh_testdir
39         dh_testroot
40         dh_clean -k
41         # Add here commands to install the package into debian/umlisp-orf.
42         dh_installdirs $(clc-systems) $(clc-umlisp-orf) $(doc-dir)
43         dh_install umlisp-orf.asd $(shell echo *.lisp) $(clc-umlisp-orf)
44         #dh_install $(shell echo *.html) $(doc-dir)
45         dh_link $(clc-umlisp-orf)/umlisp-orf.asd $(clc-systems)/umlisp-orf.asd
46
47 # Build architecture-independent files here.
48 binary-indep: build install
49
50
51 # Build architecture-dependent files here.
52 binary-arch: build install
53         dh_testdir
54         dh_testroot
55 #       dh_installdebconf       
56         dh_installdocs
57 #       dh_installmenu
58 #       dh_installlogrotate
59 #       dh_installemacsen
60 #       dh_installpam
61 #       dh_installmime
62 #       dh_installinit
63 #       dh_installcron
64 #       dh_installman
65 #       dh_installinfo
66 #       dh_undocumented
67         dh_installchangelogs
68         dh_strip
69         dh_compress
70         dh_fixperms
71 #       dh_makeshlibs
72         dh_installdeb
73 #       dh_perl
74         dh_shlibdeps
75         dh_gencontrol
76         dh_md5sums
77         dh_builddeb
78
79 binary: binary-indep binary-arch
80 .PHONY: build clean binary-indep binary-arch binary install configure
81